Back to overview
Resolved

Website Performance Degradation

Sep 3, 2026 at 9:41am UTC
Affected services
GraphQL API
Dashboard
Authentication API
Saleshub
Configurator API
Digital Retail (APAC)

Resolved
Sep 3, 2026 at 10:02am UTC

We have identified the issue and have rectified it.

Created
Sep 3, 2026 at 9:41am UTC

Website and dashboard currently has degraded performance at the moment.